目錄
- DHCP Snooping
- DHCP Option 82
- igmp snooping
DHCP Snooping
RouterOS you can specify which bridge ports are trusted
(where known DHCP server resides and DHCP messages should be forwarded)
ports are untrusted (usually used for access ports, received DHCP server messages will be dropped)
DHCP server messages = DHCP Discover & DHCP Offer
* SW 之間的 port 必須 trusted
DHCP Option 82
an additional information (Agent Circuit ID and Agent Remote ID) provided by DHCP Snooping enabled devices that allows identifying the device itself and DHCP clients.
DHCP Server <-- SW1 <-- Add Option 82 -- SW2 <-- Client
In case your DHCP server does not support DHCP Option 82 or you do not implement any Option 82 related policies,
this option can be disabled.
/interface bridge
set [find where name="bridge"] dhcp-snooping=yes add-dhcp-option82=yes
igmp snooping
* Bridge 的功能
By default, bridges are flooding multicast traffic to all bridge ports just like broadcast traffic
The IGMP/MLD snooping tries to solve the problem by forwarding the multicast traffic only to ports where clients are subscribed to
RouterOS bridge can process IGMP v1/v2/v3 and MLD v1/v2 packets. (RFC4541)
Settings
igmp-snooping (Default: no)
igmp-version (Default: 2) # IGMPv2 = RFC2236
mld-version (Default: 1) # This property only has an effect when the bridge has an active IPv6 address,
multicast-router (Default: temporary-query)
querier-interval (Default: 4m15s)
the timeout period for detected querier and multicast-router ports.
temporary-query - automatically detect multicast router state on the bridge interface using IGMP/MLD queries.
On this port, unregistered multicast streams and IGMP/MLD membership reports will be sent.
multicast-querier (Default: no)
By using this property you can make an IGMP/MLD snooping enabled bridge to generate IGMP/MLD general membership queries.
This property should be used whenever there is no active querier (PIM router or IGMP proxy) in a Layer2 network.
Without a multicast querier in a Layer2 network, the Multicast Database (MDB) is not being updated,
the learned entries will timeout and IGMP/MLD snooping will not function properly.
i.e.
在 bridge1 啟用 igmp-snooping
/interface bridge add igmp-snooping=yes multicast-querier=yes name=bridge1
Monitoring
/interface bridge mdb