WDS (wireless distribution system)

最後更新: 2015-09-02

WDS

* wireless interconnection of AP
* without the traditional requirement for a wired backbone to link them
* Layer 2 transparency
* If WDS is used, both the AP and the Station switch to the 4-address-mode

Advantage:

Preserves the MAC addresses of client frames

Diagram:

remote - - - relay - - - main_______router

 - main base station (connected to the (wired) Ethernet)
 - relay base station
 - remote base station (accepts connections from wireless clients)

特徵:

same radio channel
same method of encryption
same encryption keys
may be configured to different service set identifiers (SSIDs)
may be incompatible between different products

Technical:

 - Wireless bridging (don't allow wireless stations (STA) to access them)
 - Wireless repeating

Disadvantages:

* halved after the first retransmission (hop) being made.
   (Dual band/radio APs may avoid this problem) <=  half-duplex nature of wifi

* Dynamically assigned and rotated encryption keys are usually not supported (用唔到 WPA)

Openwrt

Depending on the wireless chipset and driver in use:
- Broadcom WDS: available on Broadcom wireless chipsets using the proprietary wl.o driver
- AP-to-Sta WDS: mac80211 supported wireless devices

 


Setting

 

/etc/config/network

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'dhcp'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel  1
        #option macaddr 'unique device MAC address here'
        option hwmode '11ng'
        option htmode 'HT20'
        option disabled 0

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option ssid 'my-wireless-ssid'
        option encryption 'psk2'
        option key 'wireless-secret-password'

        # set mode ap / sta
        option mode 'ap'
        #option mode 'sta'

        # This sets 4-address mode
        option wds '1'

Remark

* On the AP, add "option wds 1" to the existing wifi-iface section
* sta: station (STA)
* "option mode 'sta'" and "option wds 1" to the STA 's wifi-iface section
* Disable the DHCP server ON STA (/etc/config/dhcp: "option ignore 1")
* Add the newly created AP to the LAN firewall Zone

Re-enable wifi

root@OpenWrt:/etc/config# wifi

Testing

AP:

ifconfig

# 會見到多了一個 interface

wlan.staN

 


Other Solution

 

* Bridged Client Mode (with relayd)
* Routed Client Mode (wifi client)[Masqueraded / static route]

 


DOC

http://wiki.openwrt.org/doc/howto/clientmode
http://wiki.openwrt.org/doc/recipes/atheroswds

附加檔案大小
802.11-no-bridge-wds.png63.52 KB